Fix BlueSky build on modern Linux and libs3.
[bluesky.git] / libs3-1.4 / archlinux / PKGBUILD
1 # Contributor: Bryan Ischo <bryan@ischo.com>
2 pkgname=libs3
3 pkgver=1.4
4 pkgrel=1
5 pkgdesc="C Library and Tools for Amazon S3 Access"
6 arch=('i686' 'x86_64')
7 url="http://libs3.ischo.com/index.html"
8 license=('GPL')
9 groups=()
10 depends=('libxml2' 'openssl')
11 makedepends=('make')
12 provides=()
13 conflicts=()
14 replaces=()
15 backup=()
16 options=()
17 install=
18 source=(http://libs3.ischo.com/$pkgname-$pkgver.tar.gz)
19 noextract=()
20 md5sums=('source md5') #generate with 'makepkg -g'
21
22 build() {
23   cd "$srcdir/$pkgname-$pkgver"
24
25   make exported || return 1
26   cp -a build/{bin,include,lib} $pkgdir
27 }
28
29 # vim:set ts=2 sw=2 et: