Add proper per-file copyright notices/licenses and top-level license.
[bluesky.git] / kvstore / kvstore.spec
1 Name: kvstore
2 Version: 0.1
3 Release: 1
4 Summary: A Simple kv store application
5 License: BSD
6 Group:System Environment/Base
7 Source0: http://salud.ucsd.edu/~jcm/scaling/kvstore-0.1.tar.gz
8 BuildRoot: %{_tmppath}/%{name}%{version}%{release}root%(%{__id_u} jcm)
9 BuildArch: x86_64
10 Requires: boost protobuf db4
11 BuildRequires: boost-devel gtest-devel protobuf-devel db4-devel
12
13 %description
14
15 Key Value Store with simple backend and google protocol buffer rpc.
16
17 %prep
18 %setup -q
19
20 %build
21 scons %{?_smp_mflags}
22
23 %install
24 rm -rf %{buildroot}
25 mkdir -p %{buildroot}%{_bindir}
26 scons --prefix=%{buildroot} install
27
28 %clean
29 scons -c
30
31 %files
32 %defattr(-,root,root,-)
33 %{_bindir}/kvstore