Add John MucCullough's simple key/value storage server.
[bluesky.git] / kvstore / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11 build: 
12         dh_testdir
13         scons
14
15 install: build
16         dh_testdir
17         dh_testroot
18         dh_prep
19         dh_installdirs
20         scons --prefix=$(CURDIR)/debian/tmp install
21
22 clean:
23         scons -c
24         dh_clean
25
26 binary-arch: install
27         dh_testdir
28         dh_testroot
29         dh_installchangelogs
30         dh_install
31         dh_link
32         #dh_strip
33         dh_compress
34         dh_fixperms
35         dh_installdeb
36         dh_gencontrol
37         dh_md5sums
38         dh_builddeb
39
40 binary: binary-arch
41
42 %:
43         dh  $@