Work on a client for generating a synthetic stream of NFS operations.
[bluesky.git] / nfs3 / CMakeLists.txt
index de355d8..810eccb 100644 (file)
@@ -2,7 +2,11 @@ include_directories("${LIBS3_BUILD_DIR}/include")
 link_directories("${LIBS3_BUILD_DIR}/lib")
 
 add_executable(nfsproxy
-               nfsd.c rpc.c mount.c nfs3.c mount_prot_xdr.c nfs3_prot_xdr.c)
+               common.c nfsd.c rpc.c mount.c nfs3.c
+               mount_prot_xdr.c nfs3_prot_xdr.c)
+
+add_executable(synclient synclient.c common.c nfs3_prot_xdr.c)
 
 include_directories(${GLIB_INCLUDE_DIRS} "${CMAKE_SOURCE_DIR}/bluesky")
 target_link_libraries(nfsproxy bluesky ${GLIB_LIBRARIES})
+target_link_libraries(synclient ${GLIB_LIBRARIES})