Add John MucCullough's simple key/value storage server.
[bluesky.git] / kvstore / debian / rules
diff --git a/kvstore/debian/rules b/kvstore/debian/rules
new file mode 100755 (executable)
index 0000000..a47c8e4
--- /dev/null
@@ -0,0 +1,43 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+build: 
+       dh_testdir
+       scons
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_prep
+       dh_installdirs
+       scons --prefix=$(CURDIR)/debian/tmp install
+
+clean:
+       scons -c
+       dh_clean
+
+binary-arch: install
+       dh_testdir
+       dh_testroot
+       dh_installchangelogs
+       dh_install
+       dh_link
+       #dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-arch
+
+%:
+       dh  $@