1 Summary: C Library and Tools for Amazon S3 Access
6 Group: Networking/Utilities
7 URL: http://sourceforge.net/projects/reallibs3
8 Source0: libs3-1.4.tar.gz
9 Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
10 # Want to include curl dependencies, but older Fedora Core uses curl-devel,
11 # and newer Fedora Core uses libcurl-devel ... have to figure out how to
12 # handle this problem, but for now, just don't check for any curl libraries
13 # Buildrequires: curl-devel
14 Buildrequires: libxml2-devel
15 Buildrequires: openssl-devel
21 %define debug_package %{nil}
24 This package includes the libs3 shared object library, needed to run
25 applications compiled against libs3, and additionally contains the s3
26 utility for accessing Amazon S3.
29 Summary: Headers and documentation for libs3
30 Group: Development/Libraries
31 Requires: %{name} = %{version}-%{release}
34 This library provides an API for using Amazon's S3 service (see
35 http://s3.amazonaws.com). Its design goals are:
37 - To provide a simple and straightforward API for accessing all of S3's
39 - To not require the developer using libs3 to need to know anything about:
43 In other words, this API is meant to stand on its own, without requiring
44 any implicit knowledge of how S3 services are accessed using HTTP
46 - To be usable from multithreaded code
47 - To be usable by code which wants to process multiple S3 requests
48 simultaneously from a single thread
49 - To be usable in the simple, straightforward way using sequentialized
57 BUILD=$RPM_BUILD_ROOT/build make exported
60 BUILD=$RPM_BUILD_ROOT/build DESTDIR=$RPM_BUILD_ROOT/usr make install
61 rm -rf $RPM_BUILD_ROOT/build
64 rm -rf $RPM_BUILD_ROOT
67 %defattr(-,root,root,-)
72 %defattr(-,root,root,-)
77 * Sat Aug 09 2008 <bryan@ischo,com> Bryan Ischo
78 - Split into regular and devel packages.
80 * Tue Aug 05 2008 <bryan@ischo,com> Bryan Ischo