52a45b21de06093eeced73a32259caecac062c56
[bluesky.git] / libs3-1.4 / libs3.spec
1 Summary: C Library and Tools for Amazon S3 Access
2 Name: libs3
3 Version: 1.4
4 Release: 1
5 License: GPL
6 Group: Networking/Utilities
7 URL: http://sourceforge.net/projects/reallibs3
8 Source0: libs3-1.4.tar.gz
9 Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
10 # Want to include curl dependencies, but older Fedora Core uses curl-devel,
11 # and newer Fedora Core uses libcurl-devel ... have to figure out how to
12 # handle this problem, but for now, just don't check for any curl libraries
13 # Buildrequires: curl-devel
14 Buildrequires: libxml2-devel
15 Buildrequires: openssl-devel
16 Buildrequires: make
17 # Requires: libcurl
18 Requires: libxml2
19 Requires: openssl
20
21 %define debug_package %{nil}
22
23 %description
24 This package includes the libs3 shared object library, needed to run
25 applications compiled against libs3, and additionally contains the s3
26 utility for accessing Amazon S3.
27
28 %package devel
29 Summary: Headers and documentation for libs3
30 Group: Development/Libraries
31 Requires: %{name} = %{version}-%{release}
32
33 %description devel
34 This library provides an API for using Amazon's S3 service (see
35 http://s3.amazonaws.com).  Its design goals are:
36
37  - To provide a simple and straightforward API for accessing all of S3's
38    functionality
39  - To not require the developer using libs3 to need to know anything about:
40      - HTTP
41      - XML
42      - SSL
43    In other words, this API is meant to stand on its own, without requiring
44    any implicit knowledge of how S3 services are accessed using HTTP
45    protocols.
46  - To be usable from multithreaded code
47  - To be usable by code which wants to process multiple S3 requests
48    simultaneously from a single thread
49  - To be usable in the simple, straightforward way using sequentialized
50    blocking requests
51
52
53 %prep
54 %setup -q
55
56 %build
57 BUILD=$RPM_BUILD_ROOT/build make exported
58
59 %install
60 BUILD=$RPM_BUILD_ROOT/build DESTDIR=$RPM_BUILD_ROOT/usr make install
61 rm -rf $RPM_BUILD_ROOT/build
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(-,root,root,-)
68 /usr/bin/s3
69 /usr/lib/libs3.so*
70
71 %files devel
72 %defattr(-,root,root,-)
73 /usr/include/libs3.h
74 /usr/lib/libs3.a
75
76 %changelog
77 * Sat Aug 09 2008  <bryan@ischo,com> Bryan Ischo
78 - Split into regular and devel packages.
79
80 * Tue Aug 05 2008  <bryan@ischo,com> Bryan Ischo
81 - Initial build.